How to Separate vpn Traffic for Games on Mikrotik

To split traffic on a MikroTik router and route gaming traffic through a VPN, you can use policy-based routing. Here's a general outline:

1. Identify Gaming Traffic:

  • Use MikroTik's Layer 7 protocol feature or mark packets based on destination IPs/ports commonly used by gaming servers.

2. Set Up VPN:

  • Configure a VPN client on your MikroTik router (e.g., PPTP, L2TP, SSTP, or WireGuard).
  • Ensure the VPN connection is active and functional.

3. Mark Routing:

  • Use the mangle feature in the firewall to mark gaming traffic for routing through the VPN.

4. Create Routes:

  • Add a route for marked traffic to go through the VPN interface.
  • Ensure other traffic uses the default gateway.

5. Test:

  • Verify that gaming traffic is routed through the VPN while other traffic bypasses it.


# Setup L2TP VPN Client /interface l2tp-client add connect-to=your.vpn.server.com disabled=no name=l2tp-out1 password=yourpassword \ user=yourusername # Marking Game Traffic (UDP ports common for games) /ip firewall mangle add action=mark-packet chain=prerouting comment="Mark Game Traffic" new-packet-mark=\ game-traffic passthrough=yes port=27000-27200,37000-40000 protocol=udp add action=mark-packet chain=prerouting comment="Mark Game Traffic - Additional Ports" \ new-packet-mark=game-traffic passthrough=yes port=3074,3478-3480,4379-4380,27000-27050 \ protocol=udp # Marking Browsing Traffic (HTTP/HTTPS/DNS) add action=mark-packet chain=prerouting comment="Mark Browsing Traffic" \ new-packet-mark=browsing-traffic passthrough=yes port=80,443,53 protocol=tcp add action=mark-packet chain=prerouting comment="Mark DNS Traffic" \ new-packet-mark=browsing-traffic passthrough=yes port=53 protocol=udp # Routing Game Traffic through VPN /ip firewall mangle add action=mark-routing chain=prerouting new-routing-mark=game-route passthrough=yes \ packet-mark=game-traffic # Setup Routing Table for Game Traffic /ip route add distance=1 gateway=l2tp-out1 routing-mark=game-route # QoS - Prioritize Game Traffic /queue tree add name="Game Priority" parent=global packet-mark=game-traffic priority=1 add name="Browsing Priority" parent=global packet-mark=browsing-traffic priority=4
Scroll to top
Code Copied!