How to Configure Transit IP on Mikrotik

Distributing public IPs from a MikroTik router using BGP and VLAN involves several steps. Here's a general guide:

1. Configure VLANs:

  • Create VLAN interfaces under Interfaces > VLAN.
  • Assign VLAN IDs and link them to the physical interfaces.

2. Assign Public IPs:

  • Allocate public IPs to the VLAN interfaces under IP > Addresses.
  • Ensure each VLAN has its own subnet.

3. Route Public IPs:

  • Advertise the public IP range via BGP to your ISP.
  • Use Routing > Filters to control which prefixes are advertised.

4. Firewall and Security:

  • Set up firewall rules to protect your network.

# IP configuration on WAN interface (ether1) /ip address add address=172.27.7.7/24 interface=ether1 # BGP Configuration /routing bgp instance add name=bgp-instance as=65000 router-id=172.27.7.7 /routing bgp peer add name=bgp-peer remote-address=172.27.7.1 remote-as=65001 instance=bgp-instance # Local IP configuration on ether2 /ip address add address=10.2.2.1/24 interface=ether2 # VLAN and subnetting configuration /interface vlan add name=vlan28 vlan-id=28 interface=ether2 /interface vlan add name=vlan29 vlan-id=29 interface=ether2 /interface vlan add name=vlan30 vlan-id=30 interface=ether2 /ip address add address=10.2.2.2/28 interface=vlan28 /ip address add address=10.2.2.18/29 interface=vlan29 /ip address add address=10.2.2.26/30 interface=vlan30
Scroll to top
Code Copied!